Zaloguj się
Blog na Matlab.pl
Forum polskich użytkowników
 
UŻYTKOWNICY GRUPY PROFIL Zaloguj się, by sprawdzić wiadomości FAQ
 



Napisz nowy temat     Odpowiedz do tematu Zobacz poprzedni temat :: Zobacz następny temat

Symulacja pojazdu o napędzie z mechanizmem różnicowym.
Forum MATLAB Strona Główna-> Sterowanie i modelowanie systemów
Post Wysłany: 3 Października 2015, Sob 5:54 pm Temat postu: Symulacja pojazdu o napędzie z mechanizmem różnicowym. Odpowiedz z cytatem
 
AUTOR:
Sherolms



Dołączył: 03 Paź 2015
Posty: 2


Ogląda profil użytkownika Wyślij prywatną wiadomość
Witam

Chciałbym stworzyć symulację pojazdu, w Matlabie Simmechanics. Model pojazdu został stworzony w programie Solidworks, a następnie wyeksportowany do formatu pierwszej generacji w Simmechanics.
Mój problem polega na tym, że chciałbym kontrolować pojazd za pomocą danych z tabeli. Np. ustalając dla niego ścieżkę po jakiej ma się poruszać oraz korzystając z wcześniej obliczonych danych, np. prędkości kół na zakręcie czy też kąta ich ustawienia na łuku dostosować ich pozycje do ustalonej trajektorii drogi. Niestety jestem zupełnie nowym użytkownikiem tego programu i nie wiem od czego zacząć, jakich bloków użyć. Bardzo proszę, jeżeli ma ktoś pomysł jak można by to było wykonać, aby się nim podzielił.
W skład modelu wchodzi również platforma po której ma się poruszać.


 

Post Wysłany: 10 Października 2015, Sob 9:20 pm Temat postu: Odpowiedz z cytatem
 
AUTOR:
Sherolms



Dołączył: 03 Paź 2015
Posty: 2


Ogląda profil użytkownika Wyślij prywatną wiadomość
Witam ponownie

udało mi się poruszyć pojazd na zasadzie bloków "Motion Driver With Displacement Input" do których podłączam blok "From Workspace". Te ostatnie pobierają dane z tabelki którą wcześniej przygotowałem. Pojazd porusza się jednak nie potrafię go zatrzymać i wybiega po za moją platformę. Może ma ktoś z was pomysł dlaczego tak jest i jak temu zaradzić ? Jeszcze jedno pytanie, mianowicie, moja animacja troszeczkę się przycina,tzn czas nie płynie w równych odstępach, czy to jest po prostu wina sprzętu na którym pracuję czy może w programie da się coś ustawić ?


 

Forum MATLAB Strona Główna-> Sterowanie i modelowanie systemów
Wyświetl posty z ostatnich:   

Napisz nowy temat     Odpowiedz do tematu Zobacz poprzedni temat :: Zobacz następny temat

Wszystkie czasy w strefie CET (Europa)

Skocz do:  

Statystyki forum:



Od dnia 08.06.2006 forum odwiedzano 35041616
Najwięcej użytkowników 266 było obecnych 19 Lutego 2015, Czw 7:03 pm

Aktualnie online:




Najnowsze posty na forum:
Losowanie z dowolnego rozkładu  (26 Marca 2017, Nie 7:45 pm)
wycinanie fragmentu wykresu przy pomocy pętli  (25 Marca 2017, Sob 7:11 pm)
Pomoc w napisaniu funkcji - operacje na macierzy  (25 Marca 2017, Sob 12:40 pm)
Porównianie wykresów w środowisku matlab i simulink  (24 Marca 2017, Pią 2:14 am)
Komunikat Struct contents reference from a non-struct array  (23 Marca 2017, Czw 9:06 pm)
Problem z zadaniem  (23 Marca 2017, Czw 6:53 pm)
Styczna do odpowiedzi skokowej  (22 Marca 2017, Sro 11:43 am)
Zadanie z Scilab. (Wykonanie skryptu.)  (21 Marca 2017, Wto 5:06 pm)
metody rozwiazywania rownan liniowych  (20 Marca 2017, Pon 10:19 pm)
Metoda Latin Hypercube Sampling  (19 Marca 2017, Nie 7:31 pm)
Twoje prawa:
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Nie możesz ściągać plików na tym forum